   <!DOCTYPE html>        <html lang="en-ZA"><head><meta charset=utf-8><title>Mzansi is not impressed with Tito Mboweni's chicken (again), Somizi invites him for lunch</title>                                                                                                                                                                                                  <script> var timestamp = new Date().getTime();

  var dataLayer = [
    {
      'uid': '',
      'uLoggedin': 'no',
      'clientType': '',
      'clientIdUser': '',
      'clientIdTiso': '',
      'subscriber': '',
      'uOfferId': '',
      'pageType': 'Article',
      'isArticle': 'yes',
      'slug': '2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch',
      'articleAccess': 'yes',
      'contentCategory': 's-mag',
      'keywordsMetaData': 'lift,liftz,somizi,tito mboweni,siya kolisi,dinner at somizis,tito mboweni chicken,tito mboweni cooking,garlic',
      'articleWordCount': '189',
      'author': 'Cebelihle Bhengu',
      'contentType': 'free',
      'liftContent': 'yes',
      'commentsAvailable': 'no',
      'embeddedContentRelatedContent': 'no',
      'embeddedContentRichMediaAudio': 'no',
      'embeddedContentRichMediaVideo': 'no',
      'embeddedContentSocialMedia': 'yes',
      'embeddedContentSocialMediaFacebook': 'no',
      'embeddedContentSocialMediaInstagram': 'no',
      'embeddedContentSocialMediaTwitter': 'yes',
      'timestamp': timestamp.toString(),
    }]; </script>  <script> (function(t,r,a,c,k,n,o,w){t['em_ns']=k;w=1*new Date();t[k]=t[k]||function(){
     (t[k].q=t[k].q||[]).push(arguments)},t[k].t=w;n=r.createElement(a);n.async=1;
     n.src=c+'/tag'+(t.addEventListener&&'.'||'_.')+'js?'+parseInt(w/1e9, 10);
     o=r.getElementsByTagName(a)[0];o.parentNode.insertBefore(n,o)
   })(window,document,'script','https://t.effectivemeasure.net','_em'); </script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":
    new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src=
    "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,"script","dataLayer","GTM-NDHKRM"); </script> <script>var _sf_startpt=(new Date()).getTime()</script> <script>!function(n,t,a,i){n.mpfContainr||(n.mpfContainr=function(){a.push(arguments)},mpfContainr.q=a,(i=t.createElement("script")).type="application/javascript",i.async=!0,i.src="//cdn.mookie1.com/containr.js",t.head.appendChild(i))}(window,document,[]);
    mpfContainr("V2_661830",{"host": "za-gmtdmp.mookie1.com", "tagType": "learn","src.rand": "[timestamp]", "src.id" : "[add_sourceid_here]" }); </script> <noscript> <iframe src="//za-gmtdmp.mookie1.com/t/v2?tagid=V2_661830&isNoScript&src.rand=[timestamp]&src.id=[add_sourceid_here]" height=0 width=0 style=display:none;visibility:hidden></iframe> </noscript>  <script src=https://middycdn-a.akamaihd.net/bootstrap/bootstrap.js id=browsi-tag data-pubkey=tisoblackstar data-sitekey=sowetanlive async></script> <script async=async src="https://static.vic-m.co/ads/vicinity-head-tag-v1.js?zoneId=2230"></script>   <script rel=preconnect src=https://securepubads.g.doubleclick.net/tag/js/gpt.js></script> <script src=https://securepubads.g.doubleclick.net/tag/js/gpt.js async></script> <script> var googletag = googletag || {};

    googletag.cmd = googletag.cmd || []; </script>  










       <script>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</script>       <meta name=cosmos:isProduction content=true>   <meta name=referrer content=unsafe-url><meta http-equiv=X-UA-Compatible content="IE=edge"><meta name=keywords content="lift,liftz,somizi,tito mboweni,siya kolisi,dinner at somizis,tito mboweni chicken,tito mboweni cooking,garlic"><meta name=description content="Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills."><meta name=news_keywords content="lift,liftz,somizi,tito mboweni,siya kolisi,dinner at somizis,tito mboweni chicken,tito mboweni cooking,garlic"><link rel=alternate href="https://www.sowetanlive.co.za/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/" hreflang="en-ZA">   <meta name=robots content="index, follow">    <meta itemprop=description name="Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills."><link itemprop=url rel=canonical href="https://www.sowetanlive.co.za/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/">    <link rel=amphtml href="https://www.sowetanlive.co.za/amp/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/">  <script type=application/ld+json> {
                    "@context": "http://schema.org",
                    "@type": "NewsArticle",
                    "mainEntityOfPage": "https://www.sowetanlive.co.za/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/",
                    "headline": "Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch",
                    "description": "Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills.",
                    "datePublished": "24 August 2020 - 21:28",  "dateModified": "24 August 2020 - 21:28",   "author": {
                            "@type": "Person",
                            "name": "Cebelihle Bhengu"
                        },   "image": [
                            {
                                "@type": "ImageObject",
                                "url": "https://lh3.googleusercontent.com/ljcNOf2eJRDcn6pPc7tcDXirWsCd_n9jgDMQzZUH7yuykwAPtJ0XuMGp1LbCbjSxIfP9aoinTACJFuFVKn_7hA",
                                "author": "Twitter/Tito Mboweni",
                                "height": "393",
                                "width": "578"
                            }
                        ],   "publisher": {
                        "@type": "Organization",
                        "name": "SowetanLIVE",
                        "url": "https://www.sowetanlive.co.za",
                        "logo": {
                            "@type": "ImageObject",
                            "url": "https://www.sowetanlive.co.za/publication/custom/static/logos/logo.sowetan-live.png"
                        },
                        "sameAs": ["https://www.facebook.com/SowetanLIVE", "https://twitter.com/SowetanLIVE"]
                    }
                } </script>  <meta name=viewport content="initial-scale=1,maximum-scale=1,minimum-scale=1,user-scalable=no"><link rel=manifest href=/manifest.json><link rel=icon type=image/png href=/favicon.png sizes=32x32><link rel=apple-touch-icon href=/static/images/icons/app-icons/app-icon.57x57.png sizes=57x57><link rel=apple-touch-icon href=/static/images/icons/app-icons/app-icon.72x72.png sizes=72x72><link rel=apple-touch-icon href=/static/images/icons/app-icons/app-icon.76x76.png sizes=76x76><link rel=apple-touch-icon href=/static/images/icons/app-icons/app-icon.114x114.png sizes=114x114><link rel=apple-touch-icon href=/static/images/icons/app-icons/app-icon.120x120.png sizes=120x120><link rel=apple-touch-icon href=/static/images/icons/app-icons/app-icon.144x144.png sizes=144x144><link rel=apple-touch-icon href=/static/images/icons/app-icons/app-icon.152x152.png sizes=152x152><link rel=apple-touch-icon href=/static/images/icons/app-icons/app-icon.180x180.png sizes=180x180><meta property=og:url content="https://www.sowetanlive.co.za/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/"><meta property=og:title content="Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch"><meta property=og:description content="Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills."><meta property=og:type content="article"><meta property=og:site_name content="SowetanLIVE"><meta property=og:image content="https://lh3.googleusercontent.com/ljcNOf2eJRDcn6pPc7tcDXirWsCd_n9jgDMQzZUH7yuykwAPtJ0XuMGp1LbCbjSxIfP9aoinTACJFuFVKn_7hA=s1000"><meta property=og:locale content="en-ZA"><meta property=fb:app_id content="187175681849845">  <meta property=al:ios:url content="sowetan-sundayworld.facebookawake://2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch"><meta property=al:ios:app_store_id content="1148557241"><meta property=al:ios:app_name content="SowetanLIVE"><meta property=al:android:url content="sowetan-sundayworld.facebookawake://2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch"><meta property=al:android:package content="com.sowetanlive.timesmedia.sowetanlive"><meta property=al:android:app_name content="SowetanLIVE">  <meta name=twitter:card content=summary_large_image><meta name=twitter:site value="@SowetanLIVE"><meta name=twitter:creator content="@SowetanLIVE"><meta name=twitter:title content="Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch"><meta name=twitter:description content="Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills."><meta name=twitter:image:src content="https://lh3.googleusercontent.com/ljcNOf2eJRDcn6pPc7tcDXirWsCd_n9jgDMQzZUH7yuykwAPtJ0XuMGp1LbCbjSxIfP9aoinTACJFuFVKn_7hA=s1000">  <meta name=article:publisher value="https://www.sowetanlive.co.za/">    <meta name=msapplication-task content="name=TimesLive;action-uri=https://www.timeslive.co.za;icon-uri=https://www.timeslive.co.za/favicon.ico"><meta name=msapplication-task content="name=BusinessLive;action-uri=https://www.businesslive.co.za;icon-uri=https://www.businesslive.co.za/favicon.ico"><meta name=msapplication-task content="name=SowetanLive;action-uri=https://sowetanlive.co.za;icon-uri=https://www.sowetanlive.co.za/favicon.ico">      <meta name=cosmos:data content="{&#34;user&#34;:null,&#34;pageType&#34;:&#34;article&#34;,&#34;publication&#34;:{&#34;name&#34;:&#34;SowetanLIVE&#34;,&#34;show&#34;:true,&#34;usePrimaryNav&#34;:true,&#34;primary&#34;:true,&#34;urlKey&#34;:&#34;sowetan-live&#34;,&#34;routed&#34;:true,&#34;id&#34;:&#34;sowetan-live&#34;,&#34;sections&#34;:[{&#34;sections&#34;:[{&#34;id&#34;:&#34;south-africa&#34;,&#34;urlKey&#34;:&#34;south-africa&#34;,&#34;name&#34;:&#34;South Africa&#34;},{&#34;id&#34;:&#34;africa&#34;,&#34;urlKey&#34;:&#34;africa&#34;,&#34;name&#34;:&#34;Africa&#34;},{&#34;id&#34;:&#34;world&#34;,&#34;urlKey&#34;:&#34;world&#34;,&#34;name&#34;:&#34;World&#34;},{&#34;link&#34;:&#34;/group/State_Capture&#34;,&#34;name&#34;:&#34;State Capture&#34;,&#34;hideInApp&#34;:true}],&#34;id&#34;:&#34;news&#34;,&#34;urlKey&#34;:&#34;news&#34;,&#34;name&#34;:&#34;News&#34;},{&#34;cosmosArticleSlug&#34;:&#34;2020-03-17-coronavirus-update&#34;,&#34;link&#34;:&#34;/news/south-africa/2020-03-17-coronavirus-update/&#34;,&#34;name&#34;:&#34;coronavirus&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;soccer&#34;,&#34;urlKey&#34;:&#34;soccer&#34;,&#34;name&#34;:&#34;Soccer&#34;},{&#34;id&#34;:&#34;boxing&#34;,&#34;urlKey&#34;:&#34;boxing&#34;,&#34;name&#34;:&#34;Boxing&#34;},{&#34;id&#34;:&#34;cricket&#34;,&#34;urlKey&#34;:&#34;cricket&#34;,&#34;name&#34;:&#34;Cricket&#34;},{&#34;id&#34;:&#34;rugby&#34;,&#34;urlKey&#34;:&#34;rugby&#34;,&#34;name&#34;:&#34;Rugby&#34;}],&#34;id&#34;:&#34;sport&#34;,&#34;urlKey&#34;:&#34;sport&#34;,&#34;name&#34;:&#34;Sport&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;mzansis-sexiest&#34;,&#34;urlKey&#34;:&#34;mzansis-sexiest&#34;,&#34;name&#34;:&#34;Mzansi&#39;s Sexiest&#34;},{&#34;cosmosPublicationId&#34;:&#34;sowetan-live&#34;,&#34;link&#34;:&#34;/pic-of-the-day/&#34;,&#34;name&#34;:&#34;Pic of the day&#34;,&#34;cosmosSectionId&#34;:&#34;pic-of-the-day&#34;}],&#34;id&#34;:&#34;entertainment&#34;,&#34;urlKey&#34;:&#34;entertainment&#34;,&#34;name&#34;:&#34;Entertainment&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;sex-relationships&#34;,&#34;urlKey&#34;:&#34;sex-relationships&#34;,&#34;name&#34;:&#34;Sex &amp; Relationships&#34;},{&#34;id&#34;:&#34;health&#34;,&#34;urlKey&#34;:&#34;health&#34;,&#34;name&#34;:&#34;Health&#34;},{&#34;id&#34;:&#34;weddings&#34;,&#34;urlKey&#34;:&#34;weddings&#34;,&#34;name&#34;:&#34;Weddings&#34;},{&#34;link&#34;:&#34;https://www.timeslive.co.za/motoring/&#34;,&#34;name&#34;:&#34;Motoring&#34;,&#34;target&#34;:&#34;new&#34;}],&#34;id&#34;:&#34;good-life&#34;,&#34;urlKey&#34;:&#34;good-life&#34;,&#34;name&#34;:&#34;Good Life&#34;},{&#34;id&#34;:&#34;sebenza-live&#34;,&#34;urlKey&#34;:&#34;sebenza-live&#34;,&#34;name&#34;:&#34;SebenzaLIVE&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;columnists&#34;,&#34;urlKey&#34;:&#34;columnists&#34;,&#34;name&#34;:&#34;Columnists&#34;},{&#34;id&#34;:&#34;letters&#34;,&#34;urlKey&#34;:&#34;letters&#34;,&#34;name&#34;:&#34;Letters&#34;},{&#34;hidden&#34;:true,&#34;hideInApp&#34;:true,&#34;id&#34;:&#34;yalo&#34;,&#34;urlKey&#34;:&#34;yalo&#34;,&#34;name&#34;:&#34;Yalo&#34;}],&#34;id&#34;:&#34;opinion&#34;,&#34;urlKey&#34;:&#34;opinion&#34;,&#34;name&#34;:&#34;Opinion&#34;},{&#34;id&#34;:&#34;s-mag&#34;,&#34;urlKey&#34;:&#34;s-mag&#34;,&#34;name&#34;:&#34;S Mag&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;money&#34;,&#34;urlKey&#34;:&#34;money&#34;,&#34;name&#34;:&#34;Money&#34;},{&#34;link&#34;:&#34;https://www.businesslive.co.za/&#34;,&#34;name&#34;:&#34;BusinessLIVE&#34;,&#34;target&#34;:&#34;new&#34;}],&#34;id&#34;:&#34;business&#34;,&#34;urlKey&#34;:&#34;business&#34;,&#34;name&#34;:&#34;Business&#34;},{&#34;link&#34;:&#34;/video/&#34;,&#34;name&#34;:&#34;Video&#34;,&#34;hideInApp&#34;:true},{&#34;hidden&#34;:true,&#34;hideInApp&#34;:true,&#34;id&#34;:&#34;oovvuu-test&#34;,&#34;urlKey&#34;:&#34;oovvuu-test&#34;,&#34;name&#34;:&#34;oovvuu Test&#34;},{&#34;hidden&#34;:true,&#34;hideInApp&#34;:true,&#34;id&#34;:&#34;pic-of-the-day&#34;,&#34;urlKey&#34;:&#34;pic-of-the-day&#34;,&#34;name&#34;:&#34;Pic of The Day&#34;},{&#34;hidden&#34;:true,&#34;hideInApp&#34;:true,&#34;id&#34;:&#34;hot-topics&#34;,&#34;urlKey&#34;:&#34;hot-topics&#34;,&#34;name&#34;:&#34;Hot Topics&#34;},{&#34;index&#34;:false,&#34;name&#34;:&#34;Pages&#34;,&#34;hideInApp&#34;:true,&#34;urlKey&#34;:&#34;pages&#34;,&#34;hidden&#34;:true,&#34;id&#34;:&#34;pages&#34;}],&#34;strings&#34;:{}},&#34;authors&#34;:null,&#34;article&#34;:{&#34;key&#34;:5693214314987520,&#34;hide_in_app&#34;:false,&#34;push_notify&#34;:false,&#34;pub_url&#34;:&#34;/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/&#34;,&#34;slug_custom&#34;:&#34;2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch&#34;,&#34;image&#34;:{&#34;palette&#34;:[&#34;#957563&#34;,&#34;#5e4c4a&#34;,&#34;#493b39&#34;,&#34;#2d211f&#34;,&#34;#100e11&#34;],&#34;description&#34;:&#34;One Twitter user said finance minister Tito Mboweni&#39;s roast chicken looks like it has a claim with the Road Accident Fund. &#34;,&#34;created&#34;:1598253060000,&#34;blob_path&#34;:&#34;/timeslive_cosmos_images/c4a7c85a64ea15feae193554cadf543587e212d7&#34;,&#34;blob_key&#34;:&#34;AMIfv94GT9gfwLPp944gZKqCtm8YMP62PXTgd6W6x-TMu73UzmiyFSNsIBgOuA-MYM-bJoaCOejdp_oukorwr8n__X9lWsMlLfwT2plP_-_2Pp__NVTz0CWQ2gbl89Pe-e_Ey1tMlsB8mmkkP8XWIMragJrLFcf5lPaLpwRmy0-uaQS5toMRiws&#34;,&#34;average&#34;:&#34;#413331&#34;,&#34;filepath&#34;:&#34;//lh3.googleusercontent.com/ljcNOf2eJRDcn6pPc7tcDXirWsCd_n9jgDMQzZUH7yuykwAPtJ0XuMGp1LbCbjSxIfP9aoinTACJFuFVKn_7hA&#34;,&#34;height&#34;:393,&#34;width&#34;:578,&#34;state&#34;:&#34;image c4a7c85a64ea15feae193554cadf543587e212d7 was uploaded&#34;,&#34;version&#34;:1,&#34;focal_y&#34;:50,&#34;focal_x&#34;:50,&#34;key&#34;:&#34;c4a7c85a64ea15feae193554cadf543587e212d7&#34;,&#34;fingerprint&#34;:null,&#34;keywords&#34;:[&#34;tito mboweni&#34;],&#34;title&#34;:&#34;&#34;,&#34;author&#34;:&#34;Twitter/Tito Mboweni&#34;,&#34;filename&#34;:&#34;c4a7c85a64ea15feae193554cadf543587e212d7&#34;,&#34;blur&#34;:&#34;/9j/4AAQSkZJRgABAQAAAQABAAD/2wCEAAUDBAQEAwUEBAQFBQUGBwwIBwcHBw8LCwkMEQ8SEhEPERETFhwXExQaFRERGCEYGh0dHx8fExciJCIeJBweHx4BBQUFBwYHDggIDh4UERQeEh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHhUeHh4eHh4eHh4eHh4eHh4eEh4VHv/AABEIAAsAEAMBIgACEQEDEQH/xAAXAAADAQAAAAAAAAAAAAAAAAAFBgcC/8QAJBAAAQQBAwMFAAAAAAAAAAAAAQIDBBEFABIxBiFBFCNCUcH/xAAVAQEBAAAAAAAAAAAAAAAAAAAEA//EABkRAAIDAQAAAAAAAAAAAAAAAAERAAIhQf/aAAwDAQACEQMRAD8AhnS0lhWZOOyRdjKXIUBJd9ttpI+SrquDX5zrfWORTBysjFRpb2SaS13dTuWgqIJCfINdrqwOOQdFMy56OO1IjtMJdVBacKyyhR3GvsaSsDlZmS6kfhTfTuMbFHaIzaTdjyEg6mKlt5FG2Ls//9k=&#34;,&#34;content_type&#34;:&#34;image/png&#34;},&#34;author_keys&#34;:[],&#34;count_social&#34;:10,&#34;private&#34;:false,&#34;assigned&#34;:[],&#34;nova_fingerprint&#34;:&#34;cosmos_push::times-live-5260421701304320&#34;,&#34;keywords&#34;:[&#34;lift&#34;,&#34;liftz&#34;,&#34;somizi&#34;,&#34;tito mboweni&#34;,&#34;siya kolisi&#34;,&#34;dinner at somizis&#34;,&#34;tito mboweni chicken&#34;,&#34;tito mboweni cooking&#34;,&#34;garlic&#34;],&#34;count_embedded_articles&#34;:0,&#34;title_section_text&#34;:&#34;Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch&#34;,&#34;access&#34;:true,&#34;style&#34;:null,&#34;print_name&#34;:null,&#34;publication&#34;:{&#34;link&#34;:&#34;/&#34;,&#34;id&#34;:&#34;sowetan-live&#34;,&#34;primary&#34;:true,&#34;name&#34;:&#34;SowetanLIVE&#34;},&#34;title&#34;:&#34;Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch&#34;,&#34;future_publish_date&#34;:null,&#34;modified_user&#34;:&#34;thembalethuz@gmail.com&#34;,&#34;sponsor_keys&#34;:[],&#34;created_by&#34;:&#34;thembalethuz@gmail.com&#34;,&#34;priority&#34;:null,&#34;source&#34;:&#34;times-live&#34;,&#34;version&#34;:null,&#34;comments_enabled&#34;:false,&#34;subsection&#34;:null,&#34;embedded_articles_list&#34;:[],&#34;count_infographic&#34;:0,&#34;title_listing&#34;:&#34;Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch&#34;,&#34;sections&#34;:[{&#34;publication&#34;:&#34;sowetan-live&#34;,&#34;section&#34;:&#34;s-mag&#34;,&#34;subsection&#34;:&#34;&#34;,&#34;primary&#34;:true}],&#34;image_header&#34;:null,&#34;updated&#34;:null,&#34;count_blockquote&#34;:0,&#34;count_video&#34;:0,&#34;ad_tag_custom&#34;:null,&#34;print_priority&#34;:0,&#34;slug_old&#34;:[&#34;2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch&#34;],&#34;count_image&#34;:1,&#34;related_articles&#34;:null,&#34;content_type&#34;:&#34;free&#34;,&#34;authors&#34;:[&#34;Cebelihle Bhengu&#34;],&#34;print_article_key&#34;:null,&#34;count_audio&#34;:0,&#34;search_text&#34;:&#34; Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch Cebelihle Bhengu lift liftz somizi tito mboweni siya kolisi dinner at somizis tito mboweni chicken tito mboweni cooking garlic Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills.&#34;,&#34;notes&#34;:null,&#34;companies&#34;:[],&#34;modified&#34;:1598284150000,&#34;summary&#34;:null,&#34;syndicate&#34;:true,&#34;image_thumbnail&#34;:null,&#34;read_duration&#34;:63,&#34;intro_text&#34;:&#34;&#34;,&#34;print_integration&#34;:null,&#34;weight&#34;:0,&#34;print_position&#34;:null,&#34;count_words&#34;:189,&#34;lock&#34;:null,&#34;location_geo&#34;:null,&#34;print_status&#34;:null,&#34;synopsis_custom&#34;:&#34;Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills.&#34;,&#34;intro&#34;:null,&#34;sponsor&#34;:null,&#34;images&#34;:[{&#34;palette&#34;:[&#34;#957563&#34;,&#34;#5e4c4a&#34;,&#34;#493b39&#34;,&#34;#2d211f&#34;,&#34;#100e11&#34;],&#34;description&#34;:&#34;One Twitter user said finance minister Tito Mboweni&#39;s roast chicken looks like it has a claim with the Road Accident Fund. &#34;,&#34;created&#34;:1598253060000,&#34;blob_path&#34;:&#34;/timeslive_cosmos_images/c4a7c85a64ea15feae193554cadf543587e212d7&#34;,&#34;blob_key&#34;:&#34;AMIfv94GT9gfwLPp944gZKqCtm8YMP62PXTgd6W6x-TMu73UzmiyFSNsIBgOuA-MYM-bJoaCOejdp_oukorwr8n__X9lWsMlLfwT2plP_-_2Pp__NVTz0CWQ2gbl89Pe-e_Ey1tMlsB8mmkkP8XWIMragJrLFcf5lPaLpwRmy0-uaQS5toMRiws&#34;,&#34;average&#34;:&#34;#413331&#34;,&#34;filepath&#34;:&#34;//lh3.googleusercontent.com/ljcNOf2eJRDcn6pPc7tcDXirWsCd_n9jgDMQzZUH7yuykwAPtJ0XuMGp1LbCbjSxIfP9aoinTACJFuFVKn_7hA&#34;,&#34;filename&#34;:&#34;c4a7c85a64ea15feae193554cadf543587e212d7&#34;,&#34;width&#34;:578,&#34;state&#34;:&#34;image c4a7c85a64ea15feae193554cadf543587e212d7 was uploaded&#34;,&#34;version&#34;:1,&#34;focal_y&#34;:50,&#34;focal_x&#34;:50,&#34;key&#34;:&#34;c4a7c85a64ea15feae193554cadf543587e212d7&#34;,&#34;blur&#34;:&#34;/9j/4AAQSkZJRgABAQAAAQABAAD/2wCEAAUDBAQEAwUEBAQFBQUGBwwIBwcHBw8LCwkMEQ8SEhEPERETFhwXExQaFRERGCEYGh0dHx8fExciJCIeJBweHx4BBQUFBwYHDggIDh4UERQeEh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHh4eHhUeHh4eHh4eHh4eHh4eHh4eEh4VHv/AABEIAAsAEAMBIgACEQEDEQH/xAAXAAADAQAAAAAAAAAAAAAAAAAFBgcC/8QAJBAAAQQBAwMFAAAAAAAAAAAAAQIDBBEFABIxBiFBFCNCUcH/xAAVAQEBAAAAAAAAAAAAAAAAAAAEA//EABkRAAIDAQAAAAAAAAAAAAAAAAERAAIhQf/aAAwDAQACEQMRAD8AhnS0lhWZOOyRdjKXIUBJd9ttpI+SrquDX5zrfWORTBysjFRpb2SaS13dTuWgqIJCfINdrqwOOQdFMy56OO1IjtMJdVBacKyyhR3GvsaSsDlZmS6kfhTfTuMbFHaIzaTdjyEg6mKlt5FG2Ls//9k=&#34;,&#34;keywords&#34;:[&#34;tito mboweni&#34;],&#34;title&#34;:&#34;&#34;,&#34;author&#34;:&#34;Twitter/Tito Mboweni&#34;,&#34;height&#34;:393,&#34;fingerprint&#34;:null,&#34;content_type&#34;:&#34;image/png&#34;}],&#34;on_hold&#34;:false,&#34;native&#34;:false,&#34;location_name&#34;:null,&#34;author&#34;:null,&#34;section&#34;:{&#34;link&#34;:&#34;/s-mag/&#34;,&#34;name&#34;:&#34;S Mag&#34;,&#34;id&#34;:&#34;s-mag&#34;},&#34;breaking&#34;:false,&#34;location_lat&#34;:null,&#34;affected_lists&#34;:[],&#34;state&#34;:&#34;published&#34;,&#34;syndicate_status&#34;:null,&#34;show_author_card&#34;:true,&#34;title2_text&#34;:&#34;&#34;,&#34;status&#34;:&#34;published&#34;,&#34;parent&#34;:null,&#34;tags&#34;:[],&#34;print_page_no&#34;:0,&#34;social_share_text&#34;:null,&#34;title_listing_text&#34;:&#34;Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch&#34;,&#34;print_title&#34;:null,&#34;title2&#34;:null,&#34;title3&#34;:null,&#34;title_text&#34;:&#34;Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch&#34;,&#34;groups&#34;:[],&#34;active&#34;:true,&#34;slug&#34;:&#34;2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch&#34;,&#34;editors_choice&#34;:false,&#34;title_custom&#34;:null,&#34;title3_text&#34;:&#34;&#34;,&#34;created&#34;:1598284150000,&#34;print_template&#34;:null,&#34;sensitive&#34;:false,&#34;synopsis&#34;:&#34;Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills.&#34;,&#34;published&#34;:1598297321000,&#34;source_id&#34;:null,&#34;location_keywords&#34;:null,&#34;external_url&#34;:null,&#34;edit_url&#34;:&#34;/s-mag/5693214314987520/&#34;},&#34;section&#34;:{&#34;id&#34;:&#34;s-mag&#34;,&#34;urlKey&#34;:&#34;s-mag&#34;,&#34;name&#34;:&#34;S Mag&#34;},&#34;now&#34;:1598303072000,&#34;sections&#34;:[{&#34;sections&#34;:[{&#34;id&#34;:&#34;south-africa&#34;,&#34;urlKey&#34;:&#34;south-africa&#34;,&#34;name&#34;:&#34;South Africa&#34;},{&#34;id&#34;:&#34;africa&#34;,&#34;urlKey&#34;:&#34;africa&#34;,&#34;name&#34;:&#34;Africa&#34;},{&#34;id&#34;:&#34;world&#34;,&#34;urlKey&#34;:&#34;world&#34;,&#34;name&#34;:&#34;World&#34;},{&#34;link&#34;:&#34;/group/State_Capture&#34;,&#34;name&#34;:&#34;State Capture&#34;,&#34;hideInApp&#34;:true}],&#34;id&#34;:&#34;news&#34;,&#34;urlKey&#34;:&#34;news&#34;,&#34;name&#34;:&#34;News&#34;},{&#34;cosmosArticleSlug&#34;:&#34;2020-03-17-coronavirus-update&#34;,&#34;link&#34;:&#34;/news/south-africa/2020-03-17-coronavirus-update/&#34;,&#34;name&#34;:&#34;coronavirus&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;soccer&#34;,&#34;urlKey&#34;:&#34;soccer&#34;,&#34;name&#34;:&#34;Soccer&#34;},{&#34;id&#34;:&#34;boxing&#34;,&#34;urlKey&#34;:&#34;boxing&#34;,&#34;name&#34;:&#34;Boxing&#34;},{&#34;id&#34;:&#34;cricket&#34;,&#34;urlKey&#34;:&#34;cricket&#34;,&#34;name&#34;:&#34;Cricket&#34;},{&#34;id&#34;:&#34;rugby&#34;,&#34;urlKey&#34;:&#34;rugby&#34;,&#34;name&#34;:&#34;Rugby&#34;}],&#34;id&#34;:&#34;sport&#34;,&#34;urlKey&#34;:&#34;sport&#34;,&#34;name&#34;:&#34;Sport&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;mzansis-sexiest&#34;,&#34;urlKey&#34;:&#34;mzansis-sexiest&#34;,&#34;name&#34;:&#34;Mzansi&#39;s Sexiest&#34;},{&#34;cosmosPublicationId&#34;:&#34;sowetan-live&#34;,&#34;link&#34;:&#34;/pic-of-the-day/&#34;,&#34;name&#34;:&#34;Pic of the day&#34;,&#34;cosmosSectionId&#34;:&#34;pic-of-the-day&#34;}],&#34;id&#34;:&#34;entertainment&#34;,&#34;urlKey&#34;:&#34;entertainment&#34;,&#34;name&#34;:&#34;Entertainment&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;sex-relationships&#34;,&#34;urlKey&#34;:&#34;sex-relationships&#34;,&#34;name&#34;:&#34;Sex &amp; Relationships&#34;},{&#34;id&#34;:&#34;health&#34;,&#34;urlKey&#34;:&#34;health&#34;,&#34;name&#34;:&#34;Health&#34;},{&#34;id&#34;:&#34;weddings&#34;,&#34;urlKey&#34;:&#34;weddings&#34;,&#34;name&#34;:&#34;Weddings&#34;},{&#34;link&#34;:&#34;https://www.timeslive.co.za/motoring/&#34;,&#34;name&#34;:&#34;Motoring&#34;,&#34;target&#34;:&#34;new&#34;}],&#34;id&#34;:&#34;good-life&#34;,&#34;urlKey&#34;:&#34;good-life&#34;,&#34;name&#34;:&#34;Good Life&#34;},{&#34;id&#34;:&#34;sebenza-live&#34;,&#34;urlKey&#34;:&#34;sebenza-live&#34;,&#34;name&#34;:&#34;SebenzaLIVE&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;columnists&#34;,&#34;urlKey&#34;:&#34;columnists&#34;,&#34;name&#34;:&#34;Columnists&#34;},{&#34;id&#34;:&#34;letters&#34;,&#34;urlKey&#34;:&#34;letters&#34;,&#34;name&#34;:&#34;Letters&#34;},{&#34;hidden&#34;:true,&#34;hideInApp&#34;:true,&#34;id&#34;:&#34;yalo&#34;,&#34;urlKey&#34;:&#34;yalo&#34;,&#34;name&#34;:&#34;Yalo&#34;}],&#34;id&#34;:&#34;opinion&#34;,&#34;urlKey&#34;:&#34;opinion&#34;,&#34;name&#34;:&#34;Opinion&#34;},{&#34;id&#34;:&#34;s-mag&#34;,&#34;urlKey&#34;:&#34;s-mag&#34;,&#34;name&#34;:&#34;S Mag&#34;},{&#34;sections&#34;:[{&#34;id&#34;:&#34;money&#34;,&#34;urlKey&#34;:&#34;money&#34;,&#34;name&#34;:&#34;Money&#34;},{&#34;link&#34;:&#34;https://www.businesslive.co.za/&#34;,&#34;name&#34;:&#34;BusinessLIVE&#34;,&#34;target&#34;:&#34;new&#34;}],&#34;id&#34;:&#34;business&#34;,&#34;urlKey&#34;:&#34;business&#34;,&#34;name&#34;:&#34;Business&#34;},{&#34;link&#34;:&#34;/video/&#34;,&#34;name&#34;:&#34;Video&#34;,&#34;hideInApp&#34;:true},{&#34;hidden&#34;:true,&#34;hideInApp&#34;:true,&#34;id&#34;:&#34;oovvuu-test&#34;,&#34;urlKey&#34;:&#34;oovvuu-test&#34;,&#34;name&#34;:&#34;oovvuu Test&#34;},{&#34;hidden&#34;:true,&#34;hideInApp&#34;:true,&#34;id&#34;:&#34;pic-of-the-day&#34;,&#34;urlKey&#34;:&#34;pic-of-the-day&#34;,&#34;name&#34;:&#34;Pic of The Day&#34;},{&#34;hidden&#34;:true,&#34;hideInApp&#34;:true,&#34;id&#34;:&#34;hot-topics&#34;,&#34;urlKey&#34;:&#34;hot-topics&#34;,&#34;name&#34;:&#34;Hot Topics&#34;},{&#34;index&#34;:false,&#34;name&#34;:&#34;Pages&#34;,&#34;hideInApp&#34;:true,&#34;urlKey&#34;:&#34;pages&#34;,&#34;hidden&#34;:true,&#34;id&#34;:&#34;pages&#34;}],&#34;sponsors&#34;:null,&#34;subsection&#34;:null}"> <link rel="preload" href="/build/chunks/priority.72cd0565b76ee4f174e2.bundle.js" as="script" ><script type="text/javascript" src="/build/chunks/priority.72cd0565b76ee4f174e2.bundle.js"></script><link rel="preload" href="/build/chunks/priority.72cd0565b76ee4f174e2.bundle.css" as="style" ><link rel="stylesheet" href="/build/chunks/priority.72cd0565b76ee4f174e2.bundle.css"> <link rel="preload" href="/build/chunks/entry.cfbd39329309c153e541.bundle.css" as="style" ><link rel="stylesheet" href="/build/chunks/entry.cfbd39329309c153e541.bundle.css"> <link rel="preload" href="/build/chunks/pages/article.4f11854b953f337706ce.bundle.css" as="style" ><link rel="stylesheet" href="/build/chunks/pages/article.4f11854b953f337706ce.bundle.css">    <noscript> <style> .feature-phone{display: block !important;} </style> </noscript><meta name=apple-itunes-app content="app-id=1148557241, app-argument=https://www.sowetanlive.co.za/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/"><link href="https://fonts.googleapis.com/css?family=Arvo:400,700|Montserrat:400,700|Lora:400,700|Heebo:400,700,800|Playfair+Display|Lora:400,500,700|Raleway:400,500,700,700i,800,800i|Roboto|Roboto+Condensed|Open+Sans+Condensed:700&display=swap" as=style rel=preload><link href="https://fonts.googleapis.com/css?family=Arvo:400,700|Montserrat:400,700|Lora:400,700|Heebo:400,700,800|Playfair+Display|Lora:400,500,700|Raleway:400,500,700,700i,800,800i|Roboto|Roboto+Condensed|Open+Sans+Condensed:700&display=swap" rel=stylesheet><link rel=preconnect href=//www.sowetanlive.co.za><link rel=preconnect href=//lh3.googleusercontent.com>      <link rel=stylesheet type=text/css href="/build/chunks/shared-article-print.b8e07503efc43c24dc0c.bundle.css" media=print>   </head><body class="publication-sowetan-live sowetan-live">    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NDHKRM" height=0 width=0 style=display:none;visibility:hidden></iframe></noscript> <noscript> <img src=https://collector.effectivemeasure.net/noscript alt="" style="position:absolute; left:-5px;"> </noscript> <img src="//za-gmtdmp.mookie1.com/t/v2/learn?tagid=V2_661830&src.rand=[timestamp]&src.id=[add_sourceid_here]" style=display:none;>      <nav class="nav-dark nav-publication-sowetan-live ">  <div class=nav-wrapper> <div class=nav-links><ul><li id=nav-search class=search> <a> <i class="fa fa-search"></i> </a></li><li><div class=logo-button>  </div></li><li class=hamburger> <a id=hamburger> <i class="fa fa-bars"></i> </a></li></ul></div> <div class=logo>    <a href="/"></a></div> <div class=user-buttons><ul>  <li><a href=/u/sign-up/ class="corner-button register"> <i class="fa fa-user-plus" aria-hidden=true></i>Register </a></li>  <li><a href=/u/sign-in/ class="corner-button sign-in"> <i class="fa fa-sign-in" aria-hidden=true></i>Sign in </a></li> </ul></div> <div class=sections-wrap><ul class=sections>   <li>  <a href="/news/"  rel="news"> News </a>   <ul class=subsections>   <li class=dropdown>  <a href="/news/south-africa/" > South Africa </a>  </li>   <li class=dropdown>  <a href="/news/africa/" > Africa </a>  </li>   <li class=dropdown>  <a href="/news/world/" > World </a>  </li>   <li class=dropdown>  <a href="/group/State_Capture"   > State Capture </a>  </li>  </ul>  </li>   <li> <a href="/news/south-africa/2020-03-17-coronavirus-update/"   > coronavirus </a>   </li>   <li>  <a href="/sport/"  rel="sport"> Sport </a>   <ul class=subsections>   <li class=dropdown>  <a href="/sport/soccer/" > Soccer </a>  </li>   <li class=dropdown>  <a href="/sport/boxing/" > Boxing </a>  </li>   <li class=dropdown>  <a href="/sport/cricket/" > Cricket </a>  </li>   <li class=dropdown>  <a href="/sport/rugby/" > Rugby </a>  </li>  </ul>  </li>   <li>  <a href="/entertainment/"  rel="entertainment"> Entertainment </a>   <ul class=subsections>   <li class=dropdown>  <a href="/entertainment/mzansis-sexiest/" > Mzansi's Sexiest </a>  </li>   <li class=dropdown>  <a href="/pic-of-the-day/"   > Pic of the day </a>  </li>  </ul>  </li>   <li>  <a href="/good-life/"  rel="good-life"> Good Life </a>   <ul class=subsections>   <li class=dropdown>  <a href="/good-life/sex-relationships/" > Sex & Relationships </a>  </li>   <li class=dropdown>  <a href="/good-life/health/" > Health </a>  </li>   <li class=dropdown>  <a href="/good-life/weddings/" > Weddings </a>  </li>   <li class=dropdown>  <a href="https://www.timeslive.co.za/motoring/"  target=_new   > Motoring </a>  </li>  </ul>  </li>   <li>  <a href="/sebenza-live/"  rel="sebenza-live"> SebenzaLIVE </a>   </li>   <li>  <a href="/opinion/"  rel="opinion"> Opinion </a>   <ul class=subsections>   <li class=dropdown>  <a href="/opinion/columnists/" > Columnists </a>  </li>   <li class=dropdown>  <a href="/opinion/letters/" > Letters </a>  </li>    </ul>  </li>   <li>  <a href="/s-mag/"  class=selected  rel="s-mag"> S Mag </a>   </li>   <li>  <a href="/business/"  rel="business"> Business </a>   <ul class=subsections>   <li class=dropdown>  <a href="/business/money/" > Money </a>  </li>   <li class=dropdown>  <a href="https://www.businesslive.co.za/"  target=_new   > BusinessLIVE </a>  </li>  </ul>  </li>   <li> <a href="/video/"   > Video </a>   </li>            <li><div class="switch-desktop show-mobile"> <a href="https://www.sowetanlive.co.za/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/?device=feature_phone">Light Version</a></div></li> </ul><div class="social-links lg-down"><ul><li><a target=_blank rel=noopener href="https://www.facebook.com/SowetanLIVE"><i class="fa fa-facebook"></i></a></li><li><a target=_blank rel=noopener href="https://twitter.com/SowetanLIVE"><i class="fa fa-twitter"></i></a></li></ul></div></div></div></nav><html></html> <div class=wallpaper><div id=div-gpt-ad-wallpaper></div></div><div id=content class="  sowetan-live "><div class=banner><div id=div-gpt-ad-banner-1></div></div> <div class="body-content ">  <div id=article  >         <div class=article-wrapper--body><div class=container><div class=row><div class="col-md-12 col-lg-8">    <div class=category> <span class="sowetan-live">  <a href="/s-mag/" rel="s-mag"  target=_new > S Mag </a>  </span>  </div>   <div class=secondary-title> <h2 class="article-title article-title-secondary">  </h2> </div><div class=primary-title> <h1 class="article-title article-title-primary">  <span>Mzansi is not impressed with Tito Mboweni's chicken (again), Somizi invites him for lunch</span>  </h1> </div><div class=tertiary-title> <h3 class="article-title article-title-tertiary">  </h3> </div>    <div class=article-meta>  <span id=authors class=article-author data-author="<span class='authors-list'>Cebelihle Bhengu</span>"> By <span class='authors-list'>Cebelihle Bhengu</span> - </span>  <span class=article-pub-date> 24 August 2020 - 21:28 </span></div><div class=author-sponsor-meta>     </div>  <div class="social-container ">     <div class=social-links data-social-title="Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch" data-social-url="/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/" data-social-synopsis="Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills." data-social-image="//lh3.googleusercontent.com/ljcNOf2eJRDcn6pPc7tcDXirWsCd_n9jgDMQzZUH7yuykwAPtJ0XuMGp1LbCbjSxIfP9aoinTACJFuFVKn_7hA" data-social-tags="" data-social-pub="sowetan-live">  <a class="facebook social-item" href=#><i class="fa fa-facebook"></i></a> <a class="twitter social-item" target=_blank rel=noopener href=""><i class="fa fa-twitter"></i></a> <a class="pinterest social-item" target=_blank rel=noopener href=https://www.pinterest.com/pin/create/button/ ><i class="fa fa-pinterest"></i></a> <a class="email social-item" href=#><i class="fa fa-envelope"></i></a> <a id=article-print class="print article-print social-item" href=#><i class="fa fa-print"></i></a> <a class="whatsapp social-item" href=#><i class="fa fa-whatsapp"></i></a>   </div> </div>     <div class=article-widgets>       <div id="7e9989cb-baa7-451c-bf0c-594677b16228" class="article-widget article-widget-image"  rel="image">    <div class=wrap>  <div class=image-container> <a class=image data-lightbox="articlec4a7c85a64ea15feae193554cadf543587e212d7"  href="  //lh3.googleusercontent.com/ljcNOf2eJRDcn6pPc7tcDXirWsCd_n9jgDMQzZUH7yuykwAPtJ0XuMGp1LbCbjSxIfP9aoinTACJFuFVKn_7hA=s1200  " style="padding-top:67.9930795848%;"> <img src="  //lh3.googleusercontent.com/ljcNOf2eJRDcn6pPc7tcDXirWsCd_n9jgDMQzZUH7yuykwAPtJ0XuMGp1LbCbjSxIfP9aoinTACJFuFVKn_7hA=s578  " alt="One Twitter user said finance minister Tito Mboweni&#39;s roast chicken looks like it has a claim with the Road Accident Fund."> </a>  <div class=image-text>    <span class=description> One Twitter user said finance minister Tito Mboweni's roast chicken looks like it has a claim with the Road Accident Fund.  </span>   <br>   <span class=author> <span class=image-author-label>Image:</span> <span class=name> Twitter/Tito Mboweni </span> </span>  </div> </div> </div> </div>       <div id="aad537cd-d3d3-4159-9464-acff280754e7" class="article-widget article-widget-text"  rel="text">    <div class=wrap>  <div class=text>   <p>Finance minister Tito Mboweni can't seem to catch a break with South Africans who constantly criticise his cooking skills.</p><p>On Sunday, he shared that he was making a roast chicken stuffed with garlic, onion and green pepper, but Mzansi was far from impressed.</p><p>The minister appeared to be optimistic at the start when he shared that he would roast the chicken for 45 minutes.</p><p>However, he later shared a picture of his “bruised chicken”, and admitted it was not going according to plan.</p>   </div> </div> </div>       <div id="5c9f901e-1670-41db-9050-cb722e1e4deb" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">I don’t think that this is turning out according to Plan! <a href="https://t.co/NPGSK3nvIg">pic.twitter.com/NPGSK3nvIg</a></p>&mdash; Tito Mboweni (@tito_mboweni) <a href="https://twitter.com/tito_mboweni/status/1297264786040860672?ref_src=twsrc%5Etfw">August 22, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="251b0748-5d13-4bc0-a8e5-0dcfcdbd228d" class="article-widget article-widget-text"  rel="text">    <div class=wrap>  <div class=text>   <p>One <a href="https://twitter.com/iamkoshiek/status/1297267218619797504">Twitter user</a> asked the minister: “How did you make your chicken look like it has a claim with the Road Accident Fund?”</p><p>Others advised him to stay away from the kitchen and rather stick to finance and politics.</p><p>Mboweni's lack of cooking skills may have sparked a mini roast chicken challenge as TV host Somizi Mhlongo shared snaps of his roast chicken, and invited the minister for lunch at his house.</p><p>Somizi's followers asked him to invite the minister to his cooking show <em>Dinner at Somizi's </em>to teach him a few tricks.</p><p>Springbok captain Siya Kolisi posted two pictures of two roast chickens and tagged the minister.</p>   </div> </div> </div>       <div id="db75db79-16f6-4aec-8373-e9bf3ebcc9b4" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Lunch is ready.....someone pls find bro Tito tell him he is invited <a href="https://t.co/VyJtFPRjxL">pic.twitter.com/VyJtFPRjxL</a></p>&mdash; somizi somGAGA (@somizi) <a href="https://twitter.com/somizi/status/1297497144459485184?ref_src=twsrc%5Etfw">August 23, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="8b3443c3-8603-40e3-a25e-963d58a2dfe0" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Made dinner for the family tonight. Minister <a href="https://twitter.com/tito_mboweni?ref_src=twsrc%5Etfw">@tito_mboweni</a> <br>what do you think 😉?! <a href="https://t.co/EkZAaESL9l">pic.twitter.com/EkZAaESL9l</a></p>&mdash; Siya Kolisi (@SiyaKolisi_Bear) <a href="https://twitter.com/SiyaKolisi_Bear/status/1297610588365955072?ref_src=twsrc%5Etfw">August 23, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="39ee7275-91a7-4f1e-96f9-ecad06b4fb6d" class="article-widget article-widget-text"  rel="text">    <div class=wrap>  <div class=text>   <p>Here's a glimpse into the reactions:</p>   </div> </div> </div>       <div id="6d896f0a-2422-456c-8652-0f00fee8376f" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">I can&#39;t believe I died for this <a href="https://t.co/jgioh96IUc">https://t.co/jgioh96IUc</a></p>&mdash; Tito Mboweni&#39;s Chicken (@Neo_url) <a href="https://twitter.com/Neo_url/status/1297274815062126594?ref_src=twsrc%5Etfw">August 22, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="7cf76b8a-94ac-4c50-87f7-0913feff5ad9" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">The skin of the chicken disappeared like R500 B,ka nnete bophelo ke your shoes,a go hlakane selo!!! <a href="https://t.co/L1m1KHVUVx">pic.twitter.com/L1m1KHVUVx</a></p>&mdash; Thato™© 🌈 (@Thato_Rachidi) <a href="https://twitter.com/Thato_Rachidi/status/1297291967735504899?ref_src=twsrc%5Etfw">August 22, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="1886d91e-b7ba-4fa3-8500-19c0865b704e" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">When Min. Tito_mboweni opens the fridge <br>Garlic: <a href="https://t.co/hglQbyBFOZ">pic.twitter.com/hglQbyBFOZ</a></p>&mdash; Mngani kamaStende (@Charles_Dust) <a href="https://twitter.com/Charles_Dust/status/1297528984461291525?ref_src=twsrc%5Etfw">August 23, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="82f24449-8a83-42d0-ae17-4c210311f85b" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">The wing said I can&#39;t do it anymore and relocated😂😂 <a href="https://t.co/7lQJPpsafZ">pic.twitter.com/7lQJPpsafZ</a></p>&mdash; Minnie (@dineomini) <a href="https://twitter.com/dineomini/status/1297280242269270018?ref_src=twsrc%5Etfw">August 22, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="f3a3e5c9-06b0-4e70-b99e-fb4b75c4f2ec" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">The poor chicken... What kinda abuse and disrespect it went through...</p>&mdash; BlackMan@Work (@AneleT2) <a href="https://twitter.com/AneleT2/status/1297787107218423813?ref_src=twsrc%5Etfw">August 24, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="2e1fff0c-b277-40eb-8630-47d05012e911" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">No seasoning, Niks 🧂 OMG 😳  I feel sorry for this chicken.</p>&mdash; Hlengiwe Moepe (@ntuli_hlengiwe) <a href="https://twitter.com/ntuli_hlengiwe/status/1297790692182446080?ref_src=twsrc%5Etfw">August 24, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="c48fd54e-3f6b-40d1-8237-8ec022f5fb0f" class="article-widget article-widget-tweet"  rel="tweet">    <div class=wrap>  <div align=center><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Tito Mboweni is basically Rasta but in the kitchen.</p>&mdash; Siyasamkela (@SiyaMtitshana) <a href="https://twitter.com/SiyaMtitshana/status/1297413115190161408?ref_src=twsrc%5Etfw">August 23, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div> </div> </div>       <div id="7552ca98-05a2-499c-987b-1ebf95f082ed" class="article-widget article-widget-hr"  rel="hr">    <div class=wrap>  <hr>  </div> </div>    </div>     <div class="banner mobile-show"><div id=div-gpt-ad-banner-2-mobile></div></div> <div class="social-container next-article-wrapper">     <div class=social-links data-social-title="Mzansi is not impressed with Tito Mboweni&#39;s chicken (again), Somizi invites him for lunch" data-social-url="/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/" data-social-synopsis="Finance minister Tito Mboweni can&#39;t seem to catch a break with South Africans who constantly criticise his cooking skills." data-social-image="//lh3.googleusercontent.com/ljcNOf2eJRDcn6pPc7tcDXirWsCd_n9jgDMQzZUH7yuykwAPtJ0XuMGp1LbCbjSxIfP9aoinTACJFuFVKn_7hA" data-social-tags="" data-social-pub="sowetan-live">  <a class="facebook social-item" href=#><i class="fa fa-facebook"></i></a> <a class="twitter social-item" target=_blank rel=noopener href=""><i class="fa fa-twitter"></i></a> <a class="pinterest social-item" target=_blank rel=noopener href=https://www.pinterest.com/pin/create/button/ ><i class="fa fa-pinterest"></i></a> <a class="email social-item" href=#><i class="fa fa-envelope"></i></a> <a id=article-print class="print article-print social-item" href=#><i class="fa fa-print"></i></a> <a class="whatsapp social-item" href=#><i class="fa fa-whatsapp"></i></a>  <a class="next-article social-item" href="/sport/soccer/2020-08-24-themba-zwane-scores-late-winner-for-sundowns-to-set-up-mouth-watering-clash-against-chiefs/" title="Themba Zwane scores late winner for Sundowns to set up mouth-watering clash against Chiefs">Next Article<i class="fa fa-chevron-right"></i></a>   </div> </div>   <script async src=//tags.chargeplatform.com/112524/ ></script>   <script async src=//tags.chargeplatform.com/112525/ ></script>             </div> <div class="col-lg-4 col-md-12 col-12"><div class=side-bar><div class="banner side-bar-ad"><div id=div-gpt-ad-block-1></div></div> <div class=trending><div class=widget-title><h3>Trending</h3></div><ul>  <li><div class=content> <a class=title href="/s-mag/2020-08-24-ten-times-notorious-artist-rasta-botched-portraits/"> Ten times notorious artist Rasta 'botched' portraits </a></div></li> <li><div class=content> <a class=title href="/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/"> Mzansi is not impressed with Tito Mboweni's chicken (again), Somizi ... </a></div></li> <li><div class=content> <a class=title href="/s-mag/2020-08-20-in-pics-r625m-la-mansion-from-hit-show-selling-sunset-designed-in-mzansi/"> IN PICS | R625m LA mansion from hit show 'Selling Sunset' designed in ... </a></div></li> <li><div class=content> <a class=title href="/s-mag/2020-08-20-barack-obamas-2020-summer-playlist-heres-who-made-the-list/"> Barack Obama's 2020 summer playlist: here's who made the list </a></div></li> <li><div class=content> <a class=title href="/s-mag/2020-08-11-native-calling-all-aspiring-makeup-artists-get-ready-to-get-that-feeling/"> Calling all aspiring make-up artists, get ready to ‘get that feeling’ </a></div></li> </ul></div>   <div class=banner><div id=div-gpt-ad-block-2></div></div> <div class="video-block side-bar-block"><div class=widget-title><h3>Latest Videos</h3></div>   <div class=featured-video> <a class="thumbnail video-link" style="background-image:url(//lh3.googleusercontent.com/GaiLKVbnNBYFCdq4G7rfmcxBRFTVf9tligXpY4rhuIDq0kfPDFxlCU56VWGAf3nxjpA2HQXaacakNNVH_KBH5pWyFpExGTTtWg);" href="/news/south-africa/2020-08-19-gyms-open-to-reduced-numbers-no-access-to-showers/" rel="4849980407808000,adc14b50-f8ed-49b9-90ca-10b6df3655a7"> </a></div><div class=video-list><div class=video-list-block><div class=thumbnail> <a href="/news/south-africa/2020-08-19-gyms-open-to-reduced-numbers-no-access-to-showers/"> <i class="fa fa-play-circle"></i> </a></div><div class=content><div class=title> <a href="/news/south-africa/2020-08-19-gyms-open-to-reduced-numbers-no-access-to-showers/"> Back to fitness: Some gyms reopen after five-month break </a></div></div></div>   <div class=video-list-block><div class=thumbnail> <a href="/news/south-africa/2020-08-15-ban-on-alcohol-and-cigarettes-lifted-from-monday-when-sa-moves-to-level-2/"> <i class="fa fa-play-circle"></i> </a></div><div class=content><div class=title> <a href="/news/south-africa/2020-08-15-ban-on-alcohol-and-cigarettes-lifted-from-monday-when-sa-moves-to-level-2/"> Alcohol, tobacco and local travel are back: SA to move to Lockdown level 2 </a></div></div></div> </div></div>  <div class="banner sticky-container"><div class=sticky-ad><div id=div-gpt-ad-block-3></div></div></div></div></div> </div></div></div>  </div>  </div><div class=banner><div id=div-gpt-ad-banner-3></div></div><div class="stickyfooter hide"><div class=sticky-wrap> <i class=close>X</i><div class=banner><div id=div-gpt-ad-sticky></div></div></div></div><div class=thirdparty> <center id="div-gpt-ad-thirdparty-1" class="clearfix ad-wrap"> <script> if (typeof googletag !== 'undefined') {

                googletag.cmd.push(function() {
                    googletag.display("div-gpt-ad-thirdparty-1");
                });

            } </script> </center>   </div></div> <footer class="footer-publication-sowetan-live"><div class="covid19 col-12"> Read more at the SA government's <a href=http://www.sacoronavirus.co.za>online coronavirus portal</a> or use the 24-hour public hotline: 0800 029 999 </div><div class="container footer-container"><div class=row><div class="col-lg-4 main-menu col-12 padding-override-xs hide-mobile"><div class="footer-list main-menu"><div class=footer-heading> Main Menu </div><ul>   <li>  <a href="/news/"  rel="news"> News </a>  </li>   <li> <a href="/news/south-africa/2020-03-17-coronavirus-update/"   > coronavirus </a>  </li>   <li>  <a href="/sport/"  rel="sport"> Sport </a>  </li>   <li>  <a href="/entertainment/"  rel="entertainment"> Entertainment </a>  </li>   <li>  <a href="/good-life/"  rel="good-life"> Good Life </a>  </li>   <li>  <a href="/sebenza-live/"  rel="sebenza-live"> SebenzaLIVE </a>  </li>   <li>  <a href="/opinion/"  rel="opinion"> Opinion </a>  </li>   <li>  <a href="/s-mag/"  class=selected  rel="s-mag"> S Mag </a>  </li>   <li>  <a href="/business/"  rel="business"> Business </a>  </li>   <li> <a href="/video/"   > Video </a>  </li>          </ul></div></div><div class="col-lg-4 col-12 padding-override-xs"><div class=footer-list><div class=footer-heading> Read More </div><ul>  <li><a href=/about-us/ >About Us</a></li><li><a href=/about-us/ >Contact Us</a></li> <li><a href=/newsletters/ >Email Newsletters</a></li><li><a href=/advertise/ >Advertise</a></li><li><a href=/subsfaqs/ >Subscribe</a></li><li><a href="https://www.sowetanlive.co.za/s-mag/2020-08-24-mzansi-is-not-impressed-with-tito-mbowenis-chicken-again-somizi-invites-him-for-lunch/?device=mobile">Mobile Site</a></li><li><a href=/faqs/ >FAQs</a></li><li><a href=/terms/ >Terms & Conditions</a></li><li><a href=/privacy-policy/ >Privacy Policy</a></li><li><a href=/rss-feeds/ >RSS Feeds</a></li> <li><a href=http://tiso.novusgroup.co.za target=_blank rel=noopener>Careers and Tenders</a></li></ul></div></div><div class="col-lg-4 col-12 padding-override-xs hide-mobile"><div class=footer-list><div class=footer-heading> Our network </div><ul><li><a href=http://www.timeslive.co.za/ target=_blank rel=noopener>TimesLIVE</a></li><li><a href=http://www.sundaytimes.co.za/ target=_blank rel=noopener>Sunday Times</a></li><li><a href=http://www.businesslive.co.za/ target=_blank rel=noopener>BusinessLIVE</a></li><li><a href=http://www.businesslive.co.za/bd target=_blank rel=noopener>Business Day</a></li><li><a href=http://www.businesslive.co.za/fm target=_blank rel=noopener>Financial Mail</a></li><li><a href=http://www.heraldlive.co.za/ target=_blank rel=noopener>HeraldLIVE</a></li><li><a href=http://www.dispatchlive.co.za/ target=_blank rel=noopener>DispatchLIVE</a></li><li><a href=http://wantedonline.co.za/ target=_blank rel=noopener>Wanted Online</a></li><li><a href=http://select.timeslive.co.za/ target=_blank rel=noopener>Times Select</a></li><li><a href=http://www.sahomeowner.co.za/ target=_blank rel=noopener>SA Home Owner</a></li><li><a href=http://businessmediamags.co.za/ target=_blank rel=noopener>Business Media MAGS</a></li><li><a href=https://arenaevents.africa/ target=_blank rel=noopener>Arena Events</a></li><li><a href=https://www.vryeweekblad.com/ target=_blank rel=noopener>Vrye Weekblad</a></li></ul></div></div></div><div class=bar></div><div class="row copyright"><div class=col-md-8><div class=title> SowetanLIVE </div><span> &copy; 2020 Arena Holdings (Pty) Ltd. All rights reserved. <br> Use of this site constitutes acceptance of our terms & conditions and privacy policy. </span></div><div class=col-md-4> <img src=/publication/custom/static/logos/arena-holdings.logo.png alt="Arena Holdings"></div><div class=clearfix></div></div></div></footer>     <script> var _sf_async_config={};
    /** CONFIGURATION START **/
    _sf_async_config.uid = Number("54086");
    _sf_async_config.domain = "sowetanlive.co.za";
    _sf_async_config.useCanonical = true;
    _sf_async_config.sections = "desktop-sowetan-live-s-mag";
    _sf_async_config.authors = "Cebelihle Bhengu";
    /** CONFIGURATION END **/
    (function(){
    function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement("script");
        e.setAttribute("language", "javascript");
        e.setAttribute("type", "text/javascript");
        e.setAttribute("src", "//static.chartbeat.com/js/chartbeat.js");
        document.body.appendChild(e);
    }
    var oldonload = window.onload;
    window.onload = (typeof window.onload != "function") ? loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })(); </script>    <noscript><div class="feature-phone sowetan-live" style="display: none;"><div class=logo>    <a href="/?device=feature_phone"></a></div><span> Please <a href="?device=feature_phone">click here </a> to view our site optimised for your device. </span></div></noscript><link rel=preconnect href=//www.googletagservices.com><link rel=preconnect href=//securepubads.g.doubleclick.net><link rel=preconnect href=//stats.g.doubleclick.net><link rel=preconnect href=//www.googletagmanager.com><link rel=preconnect href=//adservice.google.co.za><link rel=preconnect href=//cdn.ampproject.org><link rel=preconnect href=//fonts.gstatic.com><link rel=preconnect href=//www.google-analytics.com><link rel=preconnect href=//connect.facebook.net>  <link rel="preload" href="/build/chunks/entry.cfbd39329309c153e541.bundle.js" as="script" ><script type="text/javascript" src="/build/chunks/entry.cfbd39329309c153e541.bundle.js"></script> <link rel="preload" href="/build/chunks/pages/article.4f11854b953f337706ce.bundle.js" as="script" ><script type="text/javascript" src="/build/chunks/pages/article.4f11854b953f337706ce.bundle.js"></script>    </body></html>